#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\S)[^\S\n]*\[[^][\n]*]$"
Local $sString = "First string" & @CRLF & _
"Second string [Ignore This Part]" & @CRLF & _
"Third string (1) [Ignore This Part]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" [Ignore This Part]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)