const regex = new RegExp('^.+ (..:..).+$', 'gm')
const str = `Server message: 2022-10-15 23:56:07:028
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);