re = /^.+ (..:..).+$/m
str = 'Server message: 2022-10-15 23:56:07:028
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result