$re = '/^.+ (..:..).+$/m';
$str = 'Server message: 2022-10-15 23:56:07:028
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;