import re
regex = re.compile(r"^.+ (..:..).+$", flags=re.MULTILINE)
test_str = ("Server message: 2022-10-15 23:56:07:028\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)