# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)(?:\G(?!\A)|<p(?:\s[^>]*)?\sclass="(?:[^"]*\s)?c01[\s"])(?:(?!<p[\s>]).)*?\K\.(?=.*?<\/p>)/$0 #/gm;t' <<< "<p class=\"c01 c02\">lorem ipsum. dolor sit. amet sed.</p>
<p class=\"c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class=\"c00 c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class=\"c00 c01-1 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>"