#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)(?:\G(?!\A)|<p(?:\s[^>]*)?\sclass="(?:[^"]*\s)?c01[\s"])(?:(?!<p[\s>]).)*?\K\.(?=.*?</p>)"
Local $sString = "<p class="c01 c02">lorem ipsum. dolor sit. amet sed.</p>" & @CRLF & _
"<p class="c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>" & @CRLF & _
"<p class="c00 c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>" & @CRLF & _
"<p class="c00 c01-1 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>"
Local $sSubst = "$0 #"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)