use strict;
my $str = '<p class="c01 c02">lorem ipsum. dolor sit. amet sed.</p>
<p class="c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class="c00 c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class="c00 c01-1 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>';
my $regex = qr@(?s)(?:\G(?!\A)|<p(?:\s[^>]*)?\sclass="(?:[^"]*\s)?c01[\s"])(?:(?!<p[\s>]).)*?\K\.(?=.*?</p>)@mp;
my $subst = '$0 #';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";