const regex = new RegExp('(?s)(?:\\G(?!\\A)|<p(?:\\s[^>]*)?\\sclass="(?:[^"]*\\s)?c01[\\s"])(?:(?!<p[\\s>]).)*?\\K\\.(?=.*?</p>)', 'gm')
const str = `<p class="c01 c02">lorem ipsum. dolor sit. amet sed.</p>
<p class="c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class="c00 c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class="c00 c01-1 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>`;
const subst = `$0 #`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);