import Foundation
let pattern = #"(?s)(?:\G(?!\A)|<p(?:\s[^>]*)?\sclass="(?:[^"]*\s)?c01[\s"])(?:(?!<p[\s>]).)*?\K\.(?=.*?</p>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p class="c01 c02">lorem ipsum. dolor sit. amet sed.</p>
<p class="c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class="c00 c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
<p class="c00 c01-1 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$0 #"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)