#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bJCheckBox\b\s*(?!ckx[A-Z])\w+"
Local $sString = "Valid examples:" & @CRLF & _
"" & @CRLF & _
"private JCheckBox ckxTest = new JCheckBox();" & @CRLF & _
"public javax.swing.JCheckBox ckxTest;" & @CRLF & _
"" & @CRLF & _
"Invalid examples:" & @CRLF & _
"" & @CRLF & _
"private JCheckBox" & @CRLF & _
"abcTest;" & @CRLF & _
"private JCheckBox abcckxTest;" & @CRLF & _
"private JCheckBox ckx;" & @CRLF & _
"private JCheckBox a;" & @CRLF & _
"private JCheckBox ckxfoo; // no upper case 'F'" & @CRLF & _
"private JCheckBox abcTest = new JCheckBox();" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")