re = /\bJCheckBox\b\s*(?!ckx[A-Z])\w+/m
str = 'Valid examples:
private JCheckBox ckxTest = new JCheckBox();
public javax.swing.JCheckBox ckxTest;
Invalid examples:
private JCheckBox
abcTest;
private JCheckBox abcckxTest;
private JCheckBox ckx;
private JCheckBox a;
private JCheckBox ckxfoo; // no upper case \'F\'
private JCheckBox abcTest = new JCheckBox();
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end