import Foundation
let pattern = #"\bJCheckBox\b\s*(?!ckx[A-Z])\w+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Valid examples:
private JCheckBox ckxTest = new JCheckBox();
public javax.swing.JCheckBox ckxTest;
Invalid examples:
private JCheckBox
abcTest;
private JCheckBox abcckxTest;
private JCheckBox ckx;
private JCheckBox a;
private JCheckBox ckxfoo; // no upper case 'F'
private JCheckBox abcTest = new JCheckBox();
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)