const regex = /\bJCheckBox\b\s*(?!ckx[A-Z])\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bJCheckBox\\b\\s*(?!ckx[A-Z])\\w+', 'gm')
const str = `Valid examples:
private JCheckBox ckxTest = new JCheckBox();
public javax.swing.JCheckBox ckxTest;
Invalid examples:
private JCheckBox
abcTest;
private JCheckBox abcckxTest;
private JCheckBox ckx;
private JCheckBox a;
private JCheckBox ckxfoo; // no upper case 'F'
private JCheckBox abcTest = new JCheckBox();
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}