use strict;
my $str = 'Valid examples:
private JCheckBox ckxTest = new JCheckBox();
public javax.swing.JCheckBox ckxTest;
Invalid examples:
private JCheckBox
abcTest;
private JCheckBox abcckxTest;
private JCheckBox ckx;
private JCheckBox a;
private JCheckBox ckxfoo; // no upper case \'F\'
private JCheckBox abcTest = new JCheckBox();
';
my $regex = qr/\bJCheckBox\b\s*(?!ckx[A-Z])\w+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}