# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^I log in as ([\w-]+)(?: with the contract ((?:.(?!for the protal))+))?(?: for the protal (.*))?$/user:\1 contract:\2 portal: \3/g;t' <<< "I log in as tester1 with the contract contract1 for the protal portal1"