import Foundation
let pattern = #"^I log in as ([\w-]+)(?: with the contract ((?:.(?!for the protal))+))?(?: for the protal (.*))?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I log in as tester1 with the contract contract1 for the protal portal1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"user:\1 contract:\2 portal: \3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)