import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^I log in as ([\\w-]+)(?: with the contract ((?:.(?!for the protal))+))?(?: for the protal (.*))?$";
final String string = "I log in as tester1 with the contract contract1 for the protal portal1";
final String subst = "user:\\1 contract:\\2 portal: \\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}