$re = '/^I log in as ([\w-]+)(?: with the contract ((?:.(?!for the protal))+))?(?: for the protal (.*))?$/';
$str = 'I log in as tester1 with the contract contract1 for the protal portal1';
$subst = "user:\1 contract:\2 portal: \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;