#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^I log in as ([\w-]+)(?: with the contract ((?:.(?!for the protal))+))?(?: for the protal (.*))?$"
Local $sString = "I log in as tester1 with the contract contract1 for the protal portal1"
Local $sSubst = "user:\1 contract:\2 portal: \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)