const regex = /^I log in as ([\w-]+)(?: with the contract ((?:.(?!for the protal))+))?(?: for the protal (.*))?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^I log in as ([\\w-]+)(?: with the contract ((?:.(?!for the protal))+))?(?: for the protal (.*))?$', 'g')
const str = `I log in as tester1 with the contract contract1 for the protal portal1`;
const subst = `user:\1 contract:\2 portal: \3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);