use strict;
my $str = 'I log in as tester1 with the contract contract1 for the protal portal1';
my $regex = qr/^I log in as ([\w-]+)(?: with the contract ((?:.(?!for the protal))+))?(?: for the protal (.*))?$/p;
my $subst = 'user:\\1 contract:\\2 portal: \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";