#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!,),(?!,)"
Local $sString = "-- pega as vírgulas que não tem outra vírgula antes ou depois" & @CRLF & _
"ab,cd,,ef,gh,,,ij,kl" & @CRLF & _
"" & @CRLF & _
"-- que é outro modo de dizer:" & @CRLF & _
""a regex não pega duas ou mais vírgulas seguidas"" & @CRLF & _
"a,b" & @CRLF & _
"a,,b" & @CRLF & _
"a,,,b" & @CRLF & _
"a,,,,,,,b"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")