import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!,),(?!,)";
final String string = "-- pega as vírgulas que não tem outra vírgula antes ou depois\n"
+ "ab,cd,,ef,gh,,,ij,kl\n\n"
+ "-- que é outro modo de dizer:\n"
+ "\"a regex não pega duas ou mais vírgulas seguidas\"\n"
+ "a,b\n"
+ "a,,b\n"
+ "a,,,b\n"
+ "a,,,,,,,b";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}