use strict;
my $str = '-- pega as vírgulas que não tem outra vírgula antes ou depois
ab,cd,,ef,gh,,,ij,kl
-- que é outro modo de dizer:
"a regex não pega duas ou mais vírgulas seguidas"
a,b
a,,b
a,,,b
a,,,,,,,b';
my $regex = qr/(?<!,),(?!,)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}