import Foundation
let pattern = #"(?<!,),(?!,)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-- pega as vírgulas que não tem outra vírgula antes ou depois
ab,cd,,ef,gh,,,ij,kl
-- que é outro modo de dizer:
"a regex não pega duas ou mais vírgulas seguidas"
a,b
a,,b
a,,,b
a,,,,,,,b
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)