$re = '/(?<!,),(?!,)/m';
$str = '-- pega as vírgulas que não tem outra vírgula antes ou depois
ab,cd,,ef,gh,,,ij,kl
-- que é outro modo de dizer:
"a regex não pega duas ou mais vírgulas seguidas"
a,b
a,,b
a,,,b
a,,,,,,,b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);