re = /(?<!,),(?!,)/m
str = '-- pega as vírgulas que não tem outra vírgula antes ou depois
ab,cd,,ef,gh,,,ij,kl
-- que é outro modo de dizer:
"a regex não pega duas ou mais vírgulas seguidas"
a,b
a,,b
a,,,b
a,,,,,,,b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end