const regex = /(?<!,),(?!,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!,),(?!,)', 'gm')
const str = `-- pega as vírgulas que não tem outra vírgula antes ou depois
ab,cd,,ef,gh,,,ij,kl
-- que é outro modo de dizer:
"a regex não pega duas ou mais vírgulas seguidas"
a,b
a,,b
a,,,b
a,,,,,,,b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}