using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bVores\sref\.:\s\d+-\d+\s+(\w+)";
string input = @"ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}