$re = '/\bVores\sref\.:\s\d+-\d+\s+(\w+)/m';
$str = 'ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);