package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bVores\sref\.:\s\d+-\d+\s+(\w+)`)
var str = `ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}