import re
regex = re.compile(r"\bVores\sref\.:\s\d+-\d+\s+(\w+)", flags=re.MULTILINE)
test_str = "ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")