const regex = /\bVores\sref\.:\s\d+-\d+\s+(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bVores\\sref\\.:\\s\\d+-\\d+\\s+(\\w+)', 'gm')
const str = `ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}