// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bVores\sref\.:\s\d+-\d+\s+(\w+)").unwrap();
let string = "ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}