#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?xi)" & @CRLF & _
"^" & @CRLF & _
"(?: (?<separator> [a-z] (?:[0-9/._-]?[a-z])* )" & @CRLF & _
" (?: { (?<filler> [a-z] (?:[0-9/._-]?[a-z])* ) }" & @CRLF & _
" | $" & @CRLF & _
" )" & @CRLF & _
")+" & @CRLF & _
"$"
Local $sString = "lorem{ipsumdolor}" & @CRLF & _
"duis{auteirure}exercitation" & @CRLF & _
"nemo-enim{ipsam}volupta/tem_q.uia{voluptas}" & @CRLF & _
"/{ut-enim_ad}-{minimaveniam}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"НЕ валидно" & @CRLF & _
"" & @CRLF & _
"{lorem}ipsumdolor" & @CRLF & _
"duis{auteir{u}re}exercitation" & @CRLF & _
"{ut-enim_ad}-{0minimaveniam}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")