using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?xi)
^
(?: (?<separator> [a-z] (?:[0-9/._-]?[a-z])* )
(?: { (?<filler> [a-z] (?:[0-9/._-]?[a-z])* ) }
| $
)
)+
$";
string input = @"lorem{ipsumdolor}
duis{auteirure}exercitation
nemo-enim{ipsam}volupta/tem_q.uia{voluptas}
/{ut-enim_ad}-{minimaveniam}
НЕ валидно
{lorem}ipsumdolor
duis{auteir{u}re}exercitation
{ut-enim_ad}-{0minimaveniam}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}