use strict;
my $str = 'lorem{ipsumdolor}
duis{auteirure}exercitation
nemo-enim{ipsam}volupta/tem_q.uia{voluptas}
/{ut-enim_ad}-{minimaveniam}
НЕ валидно
{lorem}ipsumdolor
duis{auteir{u}re}exercitation
{ut-enim_ad}-{0minimaveniam}';
my $regex = qr~(?xi)
^
(?: (?<separator> [a-z] (?:[0-9/._-]?[a-z])* )
(?: { (?<filler> [a-z] (?:[0-9/._-]?[a-z])* ) }
| $
)
)+
$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}