const regex = new RegExp('(?xi)
^
(?: (?<separator> [a-z] (?:[0-9/._-]?[a-z])* )
(?: { (?<filler> [a-z] (?:[0-9/._-]?[a-z])* ) }
| $
)
)+
$', 'gm')
const str = `lorem{ipsumdolor}
duis{auteirure}exercitation
nemo-enim{ipsam}volupta/tem_q.uia{voluptas}
/{ut-enim_ad}-{minimaveniam}
НЕ валидно
{lorem}ipsumdolor
duis{auteir{u}re}exercitation
{ut-enim_ad}-{0minimaveniam}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}