$re = '~(?xi)
^
(?: (?<separator> [a-z] (?:[0-9/._-]?[a-z])* )
(?: { (?<filler> [a-z] (?:[0-9/._-]?[a-z])* ) }
| $
)
)+
$~m';
$str = 'lorem{ipsumdolor}
duis{auteirure}exercitation
nemo-enim{ipsam}volupta/tem_q.uia{voluptas}
/{ut-enim_ad}-{minimaveniam}
НЕ валидно
{lorem}ipsumdolor
duis{auteir{u}re}exercitation
{ut-enim_ad}-{0minimaveniam}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);