package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?xi)
^
(?: (?<separator> [a-z] (?:[0-9/._-]?[a-z])* )
(?: { (?<filler> [a-z] (?:[0-9/._-]?[a-z])* ) }
| $
)
)+
$`)
var str = `lorem{ipsumdolor}
duis{auteirure}exercitation
nemo-enim{ipsam}volupta/tem_q.uia{voluptas}
/{ut-enim_ad}-{minimaveniam}
НЕ валидно
{lorem}ipsumdolor
duis{auteir{u}re}exercitation
{ut-enim_ad}-{0minimaveniam}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}