import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?xi)\n"
+ "^\n"
+ "(?: (?<separator> [a-z] (?:[0-9/._-]?[a-z])* )\n"
+ " (?: \\{ (?<filler> [a-z] (?:[0-9/._-]?[a-z])* ) \\}\n"
+ " | $\n"
+ " )\n"
+ ")+\n"
+ "$";
final String string = "lorem{ipsumdolor}\n"
+ "duis{auteirure}exercitation\n"
+ "nemo-enim{ipsam}volupta/tem_q.uia{voluptas}\n"
+ "/{ut-enim_ad}-{minimaveniam}\n\n\n\n"
+ "НЕ валидно\n\n"
+ "{lorem}ipsumdolor\n"
+ "duis{auteir{u}re}exercitation\n"
+ "{ut-enim_ad}-{0minimaveniam}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}