using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)
^
(?<date>\d{2}\/\d{2})
[ ]+
(?<description>[\w ]*\w(?:[ ]+\d{2}\/\d{2})?)
[ ]+
(?<value_sign>[-+]|)
[ ]*
(?<value>\d+,\d{2})
\r?\n
(?<categories>\S.*)";
string input = @"16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 + 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 4 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}