import Foundation
let pattern = #"""
(?x)
^
(?<date>\d{2}\/\d{2})
[ ]+
(?<description>[\w ]*\w(?:[ ]+\d{2}\/\d{2})?)
[ ]+
(?<value_sign>[-+]|)
[ ]*
(?<value>\d+,\d{2})
\r?\n
(?<categories>\S.*)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 + 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 4 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)