import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)\n"
+ "^\n"
+ "(?<date>\\d{2}\\/\\d{2})\n"
+ "[ ]+\n"
+ "(?<description>[\\w ]*\\w(?:[ ]+\\d{2}\\/\\d{2})?)\n"
+ "[ ]+\n"
+ "(?<value_sign>[-+]|)\n"
+ "[ ]*\n"
+ "(?<value>\\d+,\\d{2})\n"
+ "\\r?\\n\n"
+ "(?<categories>\\S.*)";
final String string = "16/04 RC GRACAS 2 - 0,02\n"
+ "SAÚDE .RECIFE\n\n"
+ "16/04 RC GRACAS 2 02/03 45,97\n"
+ "SAÚDE .RECIFE\n\n"
+ "16/04 RC GRACAS 2 02/03 + 45,97\n"
+ "SAÚDE .RECIFE\n\n"
+ "16/04 RC GRACAS 2 02/03 4 45,97\n"
+ "SAÚDE .RECIFE\n\n"
+ "16/04 RC GRACAS 2 - 0,02\n\n"
+ "SAÚDE .RECIFE\n\n"
+ "16/04 RC GRACAS 2 - 0,02\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}