$re = '/(?x)
^
(?<date>\d{2}\/\d{2})
[ ]+
(?<description>[\w ]*\w(?:[ ]+\d{2}\/\d{2})?)
[ ]+
(?<value_sign>[-+]|)
[ ]*
(?<value>\d+,\d{2})
\r?\n
(?<categories>\S.*)/m';
$str = '16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 + 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 4 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);