// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?x)
^
(?<date>\d{2}\/\d{2})
[ ]+
(?<description>[\w ]*\w(?:[ ]+\d{2}\/\d{2})?)
[ ]+
(?<value_sign>[-+]|)
[ ]*
(?<value>\d+,\d{2})
\r?\n
(?<categories>\S.*)").unwrap();
let string = "16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 + 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 4 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}