package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?x)
^
(?<date>\d{2}\/\d{2})
[ ]+
(?<description>[\w ]*\w(?:[ ]+\d{2}\/\d{2})?)
[ ]+
(?<value_sign>[-+]|)
[ ]*
(?<value>\d+,\d{2})
\r?\n
(?<categories>\S.*)`)
var str = `16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 + 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 4 45,97
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 - 0,02
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}