#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:(?:INSERT <extra_id_[0-9]+>\s*(?://|#) \[\*\] \[LINE_COMMENT\] (.+?)\n|DELETE))"
Local $sString = "INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices" & @CRLF & _
"INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")