import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:INSERT <extra_id_[0-9]+>\\s*(?://|#) \\[\\*\\] \\[LINE_COMMENT\\] (.+?)\\n|DELETE))";
final String string = "INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices\n"
+ "INSERT <extra_id_91>// [*] [LINE_COMMENT] go/totw/130#best-practices\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}